Supported Browsers

Supported Browsers

Our online battlemap editor is a browser based tool, and although we would love to support ALL browsers out there, this would be too much for our small team.

The following browsers are fully supported and should provide the best experience:
  1. Chrome 
  2. Firefox
We know that MS Edge, Safari, and other Chromium-based browsers may work, however these browsers are not officially supported and there may be issues while using an unsupported browser.  Before reporting any issues, please ensure that you can reproduce the issue within a supported browser.

For details on supported addons, please read the following article:
    • Related Articles

    • Browser Addon Considerations

      The battlemap editor is a browser based application and as such certain browser addons can cause issues.  Below is a list of supported addons that  are known safe, along with a list of known addons that should be disabled or whitelisted for ...
    • System Requirements - Deios

      The current version of Deios Alpha has the following minimum system requirements: Windows/Linux System Requirements: Windows - Windows 10 with latest updates Linux - Ubutu 20.04 LTS (virtualization not supported) CPU - Intel Haswel/AMD FX-6XXX or ...
    • System Requirements - Battlemap Editor

      The Battlemap Editor has the following requirements: Desktop or Laptop Computer (tablets and mobile devices are not supported) 8 GB of RAM An Internet connection      Note - Temporary loss of internet will not interfere with map editing. A dedicated ...
    • My map is not auto-saving while I work on it

      We have an auto-save routine in place that stores every action to your browsers local database. This helps to restore your map if you need to refresh the browser, had a browser crash or are working with an unstable network connection. But to activate ...